PDA

View Full Version : Edirol R-09 mic input fragile


becks dark
2008-02-05, 01:18 PM
Hey guys, I have an Edirol R-09 and I'm using external mics. If your using this be careful with the connection to the mic input. After about 30+ shows I noticed the connection wasn't seating properly. I think what has happened was the cord to the top of the Edirol mic input put torque around the edges of the female end which caused the loose connection. This may have been from some movement but I'm wondering if anyone else has run into this problem. I have sent it in to Roland for repair which I'm hoping to get back soon since there are a few shows comming up that I want to get. I think this question was answered at one time but could you use the line input for an external powered mic?

dorrcoq
2008-02-05, 03:42 PM
you should always use the line in for externals with a preamp, for sure.

Get a right angle plug and leave it in the jack at all times.

jamroom
2008-02-05, 07:11 PM
Yeah, this is a known problem - check taperssection for details. Mine is nearly new, but I'm leaving my R/A jacked cable in the line in all the time - just in case. Perhaps I should have some pre-emptive surgery done.

becks dark
2008-02-06, 07:14 PM
Thanks for the info. I get to wait 2 weeks for repair:disbelief

Seth01
2008-02-07, 08:42 PM
Thanks for the info. I get to wait 2 weeks for repair:disbelief

Believe me if you get it back that fast consider yourself lucky. I've heard horror stories of it taking much, much longer.

Good luck,
Seth