PDA

View Full Version : static ip address


Slab
2006-02-03, 09:56 AM
hi, i am trying to forward ports to my router so that i am no longer firewalled. i am using mac os x 2.8. i have visited portforward.com and it says i need a static ip address. my isp tells me they do not offer this, only dynamic ip address. i followed instructions for my particular router at portforward.com leaving out static ip address.
seems i am still firewalled.
any suggestions?
thanks
Slab

jazzbo
2006-02-03, 10:09 AM
hi, i am trying to forward ports to my router so that i am no longer firewalled. i am using mac os x 2.8. i have visited portforward.com and it says i need a static ip address. my isp tells me they do not offer this, only dynamic ip address. i followed instructions for my particular router at portforward.com leaving out static ip address.
seems i am still firewalled.


If the instructions say you need an external static IP address, e.g. your ISP needs to supply one, then they are wrong.

More likely what they mean is you need a static internal IP address. That is, if your router assigns the ip address to your Mac then it needs to assign a static address so that a static routing rule can be set up to forward connections to that specific machine between the router.

U2Lynne
2006-02-03, 10:53 AM
What the instructions need to say is you need a static *local* IP. That is the one that looks like 192.168.1.xxx.

Go to your router and turn DHCP off (or some routers allow you to have it DHCP with manual, but you need to know the range it allows for manual ones - look in your manual for that). Then go to System Preferences > Network > Built-in Ethernet > (Configure) > Configure IPv4 set to Manually; IP Address set to 192.168.1.xxx (pick your own xxx, but remember them); Router set to 192.168.1.1; the rest should be from your ISP > Apply. Now go to your router to forward your ports, the IP you want to forward them to is the one you just input - 192.168.1.xxx

Slab
2006-02-03, 12:01 PM
cheers, i am going to take a short break to let my brain cool down, it seems to have overheated.
i will report on how i got on with the port forwarding when i resume a little later.
many thanks to both of you.