PDA

View Full Version : Firewalled, can't find solutions


Mouse Rapist
2013-06-16, 04:19 PM
I have got Huawei E589 router. Utorrent 3.3.
I have tried to port forward it but it doesn't appear to work. http://www.canyouseeme.org/ gives an error. I did change my IP to static.

http://img580.imageshack.us/img580/6161/ixni.jpg (http://imageshack.us/photo/my-images/580/ixni.jpg/)
http://img850.imageshack.us/img850/8762/zrb.jpg (http://imageshack.us/photo/my-images/850/zrb.jpg/)
http://img706.imageshack.us/img706/8594/nq4z.jpg (http://imageshack.us/photo/my-images/706/nq4z.jpg/)

direwolf-pgh
2013-06-16, 09:33 PM
in the Huawei E589 router -- check the Firewall/SPI settings and test.
Or remove your Virtual Server settings and configure a Port Forward under: Advanced> NAT> Port Mapping.

also, many routers require a power cycle (turn off/turn on) for settings to take effect.

paddington
2013-06-16, 09:39 PM
Many firewalls / routers forward prt 80 by default.... You could try that. Also skirts the packet sniffing meddling by some ISPs who assume port 80 is only browser traffic. Or 8080.

Mouse Rapist
2013-06-17, 01:26 PM
in the Huawei E589 router -- check the Firewall/SPI settings and test.
Or remove your Virtual Server settings and configure a Port Forward under: Advanced> NAT> Port Mapping.

also, many routers require a power cycle (turn off/turn on) for settings to take effect.

I did check the Firewall, it was disabled, I enabled it but that didn't change anything so I turned it off again.

Also there is no NAT option. Only LAN IP Filter. Could this be it? Anyway, I configured it but didn't work as well.

http://img199.imageshack.us/img199/9259/8fgz.jpg (http://imageshack.us/photo/my-images/199/8fgz.jpg/)

direwolf-pgh
2013-06-17, 04:34 PM
that's a cool little router. couple quick thoughts.
See if you can set Protocol to 'All' in the Virtual server - test out
Perhaps config your .50 wrkstn to the DMZ at which point the wrkstn software firewall can be tested out.

good luck!

Mouse Rapist
2013-06-17, 05:17 PM
Well, the Protocol options are TCP/UDP , TCP, UDP. TCP/UDP is selected, that means it's set to all, I assume.
DMZ is enabled. What exactly you mean by configuring it? I'm noob at this stuff, please excuse me :)

http://img600.imageshack.us/img600/9418/0j48.jpg (http://imageshack.us/photo/my-images/600/0j48.jpg/)

Somehow I feel I'll never be able to get this to work lol :D

direwolf-pgh
2013-06-17, 05:19 PM
well, once you drop an internal IP into the DZM.. its ass is naked to the net.
time for canyouseeme.org & shieldsup (https://www.grc.com/x/ne.dll?bh0bkyd2)

Mouse Rapist
2014-07-21, 06:12 AM
well, once you drop an internal IP into the DZM.. its ass is naked to the net.
time for canyouseeme.org & shieldsup (https://www.grc.com/x/ne.dll?bh0bkyd2)

Sorry for the very late reply :p

http://i1273.photobucket.com/albums/y418/MouseRapist/canuseeme_zpsad25e744.jpg (http://s1273.photobucket.com/user/MouseRapist/media/canuseeme_zpsad25e744.jpg.html)

http://i1273.photobucket.com/albums/y418/MouseRapist/shieldsup_zps19756c55.jpg (http://s1273.photobucket.com/user/MouseRapist/media/shieldsup_zps19756c55.jpg.html)

shakey234
2014-07-23, 01:53 PM
Here is what http://portforward.com/ write about Huawei Routers:
"Open Port on Huawei Routers
Huawei routers are typically easy to configure, and their port forwarding section is no different. Some routers have a list of places where you can forward a port, where others have to be added one at a time. Huawei sometimes refers to a port forward as a server which might confuse some, but overall they are fairly easy to set up.
If you cannot find your exact router in the list below, try following one of our Huawei HG530 guides.
That should get you an open port on pretty much any Huawei router."
Source: http://portforward.com/english/routers/port_forwarding/Huawei/default.htm

http://portforward.com/ don't have a guide for your model, Huawei E589, but you might be able to use the info for "Port Forwarding the Huawei HG530 Router for Utorrent" here:
http://portforward.com/english/routers/port_forwarding/Huawei/HG530/Utorrent.htm

There is a video on YouTube called "How to port forward a Huawei router" here:
http://www.youtube.com/watch?v=KfCEtzqlyVM

Mouse Rapist
2014-07-24, 05:00 AM
Here is what http://portforward.com/ write about Huawei Routers:
"Open Port on Huawei Routers
Huawei routers are typically easy to configure, and their port forwarding section is no different. Some routers have a list of places where you can forward a port, where others have to be added one at a time. Huawei sometimes refers to a port forward as a server which might confuse some, but overall they are fairly easy to set up.
If you cannot find your exact router in the list below, try following one of our Huawei HG530 guides.
That should get you an open port on pretty much any Huawei router."
Source: http://portforward.com/english/routers/port_forwarding/Huawei/default.htm

http://portforward.com/ don't have a guide for your model, Huawei E589, but you might be able to use the info for "Port Forwarding the Huawei HG530 Router for Utorrent" here:
http://portforward.com/english/routers/port_forwarding/Huawei/HG530/Utorrent.htm

There is a video on YouTube called "How to port forward a Huawei router" here:
http://www.youtube.com/watch?v=KfCEtzqlyVM

I already "opened" the port as seen in the first post.

http://img580.imageshack.us/img580/6161/ixni.jpg (http://imageshack.us/photo/my-images/580/ixni.jpg/)

That's everything what's available in Virtual Server settings on my router. It doesn't have more specific stuff like application selection etc seen in those tutorials. It's just what you see in the screenshot and I filled in all of that. Still, doesn't work.

I did disable firewall on the router and Windows Firewall has uTorrent exception.

When I run the uTorrent test it either says -

"Neither NAT-PMP nor uPnP is enabled. Please check your preferences." while they are actually enabled.
or
"Port is not open (you are still able to download)."

Drgiggles1
2014-07-24, 11:56 AM
Make sure the port used for Utorrent matches what's in the picture. Also make sure in the same window that nothing is checked off except the firewall exception. On my router when I access it there is a way to enable uPNP and NAT. Look for that in your router settings

Mouse Rapist
2014-07-24, 03:10 PM
Make sure the port used for Utorrent matches what's in the picture. Also make sure in the same window that nothing is checked off except the firewall exception. On my router when I access it there is a way to enable uPNP and NAT. Look for that in your router settings

Yes it does match.

Nope, my router doesn't have uPNP & NAT settings. I guess this is the key why I won't be able to do anything. I suppose these are turned off on the router by default or something.

Drgiggles1
2014-07-24, 04:04 PM
Make sure the port used for Utorrent matches what's in the picture. Also make sure in the same window that nothing is checked off except the firewall exception. On my router when I access it there is a way to enable uPNP and NAT. Look for that in your router settings

Yes it does match.

Nope, my router doesn't have uPNP & NAT settings. I guess this is the key why I won't be able to do anything. I suppose these are turned off on the router by default or something.
I know my router is different but in my case when I log into the router on the screen I find my NAT setting to be in Setup (advance routing tab) and upnp setting is in the Administration tab, same place where you can change the userid/password for router access. Hope this helps, otherwise I'm out of ideas for your router type.

Mouse Rapist
2014-07-24, 04:39 PM
Make sure the port used for Utorrent matches what's in the picture. Also make sure in the same window that nothing is checked off except the firewall exception. On my router when I access it there is a way to enable uPNP and NAT. Look for that in your router settings

Yes it does match.

Nope, my router doesn't have uPNP & NAT settings. I guess this is the key why I won't be able to do anything. I suppose these are turned off on the router by default or something.
I know my router is different but in my case when I log into the router on the screen I find my NAT setting to be in Setup (advance routing tab) and upnp setting is in the Administration tab, same place where you can change the userid/password for router access. Hope this helps, otherwise I'm out of ideas for your router type.

Googled a bit and seems like I got the answer -

https://twitter.com/HuaweiDevice/status/287031736930545664