PDA

View Full Version : TLH help ... shn > flac ... file disappears


clydevins
2011-12-21, 06:50 PM
Hey experts - first time I've come across this issue - any suggestions/ideas/help.

I have a folder of SHN files that I'm trying to convert to FLAC. I've done this 1000 times. I add them to TLH and select convert and it seems to go through the process of converting and in the folder I can see the results but as soon as each conversion is done the converted file gets deleted ???

When I right click on folder it says Read Only so I tried to uncheck but when I view properties again it goes back to Read Only.

I tried copying files to another folder and the same thing happens there.

From the cmd line I looked at the attrib flags and it says A (Archival) so I removed that flag and that didn't help either.

Anybody ???

P A U L
2011-12-21, 07:06 PM
the flac file disappears?

does tlh have an error warning, or anything in the log?

clydevins
2011-12-21, 07:49 PM
No error message. It shows/proceeds like it is working normally.

I typically write to the same folder where the source files are but I've also tried to write to a different file and the same thing happens.

Say I'm trying to convert 5 files. TLH says each of the files has been successfully converted and no errors occurrred.

When I switch over to the folder I can see each file converted over to flac and then immediately deleted and the next one started/finished/deleted.

Bizarre ? I'm stumped. Anybody ?

P A U L
2011-12-21, 08:43 PM
I'd say try deleting TLH & upgrade to the newest version. See if that helps...

clydevins
2011-12-21, 08:51 PM
That was the second/third thing I did because trying a different folder of shn's and trying to copy/move the files to a different folder.

Meaning - Traders Little Helper seems to be working fine. Never had a problem with it and I tried it on different folder and it worked fine.

I've also tried converting them one by one and randomly but each one converts and then immediately deletes.

What would cause that ? I'm not getting any errors like the files can't be converted or anything - the process says that it is working. And they appear in the folder only to disappear when completed.

P A U L
2011-12-21, 09:01 PM
Ok, then it's most likely a folder/os issue. What os?

try this:

http://xrecode.com/

clydevins
2011-12-21, 10:23 PM
Windows XP.

I'll check out the link you suggested.

clydevins
2011-12-21, 11:26 PM
Don't wish to install a different product especially a demo product.

Trying to figure out why Trader's Little Helper is doing what it is doing and how to remedy ?

Still no luck, anybody ?

P A U L
2011-12-22, 12:36 AM
well, that's the product I use, the demo is indefinite, just have to wait 4 seconds before it's active. I just figured that in this thread (started by the maker of TLH)

http://www.thetradersden.org/forums/showthread.php?t=3904

is stating that others are having trouble trying to convert SHN files. This program excels where TLH fails. I started using it because I was finding bootlegs on Japanese sites that I couldn't find anywhere else. TLH won't convert Japanese flac, so I found exrecode & it converted them without a hitch...

Your best bet is to contact the OP of the thread (roann), since he's the architect of TLH, if you're not wanting to try out other solutions...

Good luck!

tonebloke
2011-12-22, 01:32 AM
Don't wish to install a different product

Still no luck, anybody ?

Get dbPowerAmp. It's free, and will convert anything - easy!

clydevins
2011-12-22, 02:32 AM
I was able to get foobar2000 to convert them without a problem but I'm still quite baffled by TLH having problems since I've never had an issue with it before and since changing the attributes to the folder/files did not seem to make a difference.

jabulon
2011-12-22, 07:32 AM
Hi clyde. Are you trying to convert shn directly into flac? Have you tried converting the shn's into wav first and then into flac and what happens than, do the files get deleted as well?

clydevins
2011-12-22, 03:09 PM
I tried renaming the folder. Transferring the contents to another folder. And writing the conversion outputs to a different file all with the same result.

I will do that extra step just to see what happens ... certainly very curious. The implication being that you think it is a flac.exe error perhaps. Odd that at least TLH seems to think it works fine (no error message etc).

clydevins
2011-12-22, 03:20 PM
I was able to decode the shn file to wav and then encode the wav to flac without any issue. So ... that would rule out the permission issue with respect to the folder, correct ?
Note that while it did convert wav to flac successfully without errors etc it did indicate the following: successfully encoded to 'Track 19.flac' (ratio = 0.605; foreign metadata 'ID3' removed) which I've never seen on a conversion before.


But the shn to flac still deletes the file.