PDA

View Full Version : Azureus Bittorrent Help


Thomas Cantley
2005-06-06, 11:08 PM
Determined to stop being a leecher, I opened up the ports on my firewall of 6881-6889. In Azureus options under connection I have the incoming TCP listen port set to 6881 and bind to local IP address set to my IP address. After doing all this I am still leeching. Upon starting Azureus I get two errors, the first reading

Error: Failed to establish listen on port UDP:6881. Check that other applications aren't already using this port. Also check for another copy of Azureus running.

and

Error while processing advanced socket options: Cannot assign requested address: bind

I'm really not good with computers so I can't really understand any of this, and I'm sure I'm doing something stupid, but could someone help me out? I still am downloading and uploading but at slow speeds.

Any help would be appreciated,

Thomas

U2Lynne
2005-06-06, 11:35 PM
Hi Thomas, what OS are you using?

Thomas Cantley
2005-06-07, 07:40 AM
Windows XP

U2Lynne
2005-06-07, 10:49 AM
Did you open up the ports in both your Win XP firewall and in your router? Also, in Azureus, did you do a check there and see if it says your port is open (on a Mac you use the Configuration Wizard and go to the screen that says NAT/Server Port and hit the button to check the listening port)?

Thomas Cantley
2005-06-07, 02:13 PM
The ports are open on my WinXP firewall and it is currently disabled. When running the NAT/Server Port Test, I get

Testing port 6881....NAT error.

Also, I have a yellow grim face icon next to my torrents; when the cursor is placed on these icons, it says: "means that the trackers is ok, you're connected to peers, but you don't have any remote connection. You may have a NAT problem if your torrents stay on yellow status all the time."

I guess I have some sort of NAT problem, but I don't know what else to do.

Ted
2005-06-07, 02:43 PM
Are you on a network or do you have a router? If using a router, give the make/model number please.

If so, after reading this "bind to local IP address set to my IP address" from your first post, I'm thinking you may have used the wrong IP adderss to bind to.

If you do have a router, you'll need the IP address assigned to your computer by the router (your LAN IP). You'll also need to forward the appropriate ports to that same IP address. If you're on a network, you'll basically have to do the same thing as with the router.

To get your WAN IP (the one you need if NOT on a network or using a router, go to HERE. (http://www.whatismyip.com/)

To get your LAN IP (the one if you ARE on a network and/or using a router, go to your Start Menu and look for the shortcut to "Command Prompt". Hit that shortcut and then type in the window (without the quotes) "systeminfo". After a few seconds, you'll get a bunch of information about your system, including your LAN IP. It'll probably be at the bottom under IP Address (es). It is NOT the DHCP address.

You didn't say if you were using XP Home or Pro. I'm not sure if it works on XP Home. If not, let me know and I'll help you find it.

Thomas Cantley
2005-06-07, 06:28 PM
I am on a small home network and using XP Pro. I changed the IP address to my LAN IP found in the system info. The two errors I mentioned earlier have now gone away upon starting Azureus. Ports 6881-6889 are fowarded to this address. For some reason, the torrents are still yellow. I'm using a linksys.

Ted
2005-06-07, 06:57 PM
I don't use Azureus, so that's about all I can help except to ask if you enabled both TCP and UDP in your router for the port range you forwarded. I'm not sure which Azureus requires, so enable both to cover all bases.

Just to be sure you read the correct LAN IP, it should be 192.168.1.xxx - the xxx being a three-digit number, NOT a single "1".

Oh, and check Azureus' settings to see that it is set to use those same ports. Some clients allow you to change the ports used.

Thomas Cantley
2005-06-07, 07:05 PM
What client do you use?

Ted
2005-06-07, 08:45 PM
I use Shareaza, but I don't recommend it. It's crap, but I have my reasons ;)

I tried Azureus, but it crashes my firewall for some reason and I just don't feel like trying to figure out why right now. You should be able to get Azureus running though. See if there's a forum somewhere on the net for it. I'm sure your problem isn't unique.

A friend of mine swears by BitComet, if you're looking for something else to try. I'm sure other people here can give some good alternatives too, but from what I've read all over, Azureus is supposed to be about the best.

Thomas Cantley
2005-06-07, 08:46 PM
Ack, tried Bittornado and the original client and am having the same issues. I think I will try downloading a torrent on one of the other computers on the network to see if it is some internal computer thing on this one. (if thats possible). I've got the router configured, the client configured, windows firewall off, anti-virus off right now.....can't figure out what the problem is.

Ted
2005-06-07, 09:35 PM
Ah, anti-virus. Keep that on, but it reminds me that Norton's newer versions have a "worm blocker". If you're using Norton AV, check to see if it was blocked there, but you really should keep the AV part enabled. If you're using another brand AV, check to see if it has something similar to worm blocking.

Thomas Cantley
2005-06-07, 11:21 PM
Alright cool thanks for you guys' ideas.....it has certainly improved, and i think i can figure the rest of it out at an azureus specific forum. Thanks!