View Full Version : How to align sectors?

2009-12-17, 01:04 PM
New member here with another naive question. I'm sure this has been covered, and in fact I saw it in a post a few days ago, but now I can't find it anywhere in the FAQ or in the search function. I've got an audio show ready to go as .wav tracks, and I see from the guidelines that I need to eliminate sectors boundary errors before encoding as Flac files. The Flac encoding I think I can do. I have just downloaded FLAC and also CDWave, but I can't quite figure out how to use them to do this.

I tried adding the wave files to FLAC and checking the "sector align" box, but it started with the last file first and then went through the rest of the tunes. I saw a note that it should process them in order, and so I'm worried about the fact that it started with the last track. And it wrote a little note after each track telling me that so many samples were being carried over due to sector errors, but I don't know if that means the errors were being corrected or if it's telling me things are screwed up.

Also, what's a cue sheet? Do I need to create filename for one, and if so, will a cue sheet be generated? Or do I need to somehow create a cuesheet in advance and tell FLAC what to do with it before encoding?

I edited the original wave file in Adobe Audition and then cut it up into tracks using Audition, and I hope that's not an irreversible error. Can someone talk me through the process fixing the sector errors? I hope to get my first upload done today. Thanks very much!

2009-12-17, 03:59 PM
You don't need to worry about cue sheets. Once you have your project completed, export file as a WAV file to a destination. Than you can open that single WAV file with CD Wave, play the wav, and at the end of each song click on the button "split" to separate your tracks. Before closing out of cdwav click on file and save to save all wav files in your directory. Now that you have all your WAV files in a folder now launch TLH and under format click on encode wav files, set your encoding options as format flac, level 8, check align on sector boundaries using fix, set output options to your liking, check on test encoded files, check on create checksum file and select ffp as checksum type. An md5 file can be created later by selecting md5 instead of ffp.

2009-12-17, 06:46 PM
Thanks for the info. I was able to do the conversion to flac files and do the sector alignment. But as a test, I decided to convert them back to .wav files and burn them to CD to see how it sounded. For some reason, the CDs won't play on my CD player. The files themselves play on my PC. The CD's will *sometimes* play on my PC--I made several attempts using different files (some decoded from flac, some not) and I can't find a pattern. I tried a different burner, and the same thing happened.

I also tried more than one burning application, but none of them play on my CD player. But commercially-made CDs play just fine, and a CD-R that I burned yesterday plays just fine. I can't narrow it down to if it's the burner or the software or the files.

2009-12-18, 01:33 PM
could be the brand of discs, could be a bad burn