PDA

View Full Version : Firewalled; Unsuccessful attempts to forward ports


dmonte
2008-05-06, 06:37 PM
Stats: Windows XP Home (Windows Firewall disabled); Linksys BEFW11S4 wireless Router; Motorola DSL Modem (unknown model number); AT&T Internet Security Suite Anti-Virus

I have a larger laptop (desktop-replacement sized) computer that is plugged into the router via ethernet cable. It also has a built-in wireless antenna that is always on, so it receives signal from the router wirelessly. So, when I pull up "Network Connections" from the control panel, it shows both connections ... the wireless connection and the LAN connection. Both show a status of "Connected".

In order to avoid multiple ways of accessing the internet, I disconnected the LAN connection, so that I was only connecting wirelessly. Then I went through the intstructions at PortForward to establish a Static IP, then to forward the ports on my router.

However, once that was complete, I was still showing up as being firewalled. I tested the system at canyouseeme.org and it couldn't see that port that I forwarded. So now I'm not sure what to do next.

I think there could be an issue with the DSL modem and the router with regard to forwarding the ports ... but I don't know how to fix it.

I'd be grateful for any suggestions.
D

U2Lynne
2008-05-06, 06:43 PM
I assume you have the same port forwarded in your bittorrent client as in the router. Did you do anything regarding allowing your bittorrent client to be forwarded through your anti-virus application?

dmonte
2008-05-07, 09:59 AM
Yes ... I tried forwarding the same port that BitTorrent was using.

Regarding the Anti-Virus ... I didn't change any settings. And I'm not sure how I would. The antivirus came as part of the DSL package. It has limited user options.

However, in researching this, I noticed that the AT&T Firewall does have some Port allow/block preferences. Perhaps that is where my problem is?

I'm going to give that a try next and see if it works.

dmonte
2008-05-07, 03:14 PM
Ok Lynne - help me figure this one out.

I set my AT&T Firewall to allow me access to the port that BitTorrent is using. I then unplugged the ethernet cable from my computer, so instead of connecting directly to the router, i was connecting to the router wirelessly. I then went through the instructions to set a Static IP, and forward the port on the router.

Success! I logged on this site and it no longer showed that I was firewalled.

So, I then reconnected the ethernet cable, so that now i was connected to the router via the cable. I set a new static IP for that connection. I then forwarded the same port for BitTorrent on the router ... but using the 2nd Static IP. Everything seemed to work fine ... until I logged on this site and saw that once again, I was Firewalled.

So now what am I doing wrong? I don't move this computer, so it always stays connected to the router via the ethernet cable. I'd like to keep it that way because I think I'm getting faster internet access via Ethernet than I am via Wireless.

Any help would be appreciated.

dmonte
2008-05-07, 03:23 PM
Follow-up to my last post -

I plugged the ethernet cable back in, and exited BitTorrent. I went to this site and it no longer said I was Firewalled. Odd. So then I started BitTorrent, closed my browser, opened my browser and came back to this site ... it said I was Firewalled. Odd. Closed BitTorrent, tried again ... not Firewalled. Opened Bittorrent, came back to the site ... Firewalled!

So it is only showing that I'm Firewalled when I have BitTorrent running. When it is not running, I'm not showing up as Firewalled.

Does that help any?

U2Lynne
2008-05-07, 03:34 PM
This site can only tell if you are firewalled if you are using the tracker. So, it isn't surprising that when you had bittorrent closed and accessed the site that it no longer said "firewalled."

As for the post before that, you cannot forward the same port number to different IPs. That is why what you are doing isn't working. If you have it working wirelessly, then when you connect via ethernet and you are using a different IP, you need to change the port number.

dmonte
2008-05-07, 04:24 PM
As for the post before that, you cannot forward the same port number to different IPs. That is why what you are doing isn't working. If you have it working wirelessly, then when you connect via ethernet and you are using a different IP, you need to change the port number.

I removed the forwarded port from the Wireless connection's static IP address ... and I left the forwarded port for the LAN connection, which is how I'm connected now.

The port number is the same port number listed in BitTorrent under "Port used for Incoming Connections". That is the port I'm forwarding on my router, the port i've allowed in AT&T Firewall, and the port I'm forwarding for the Static IP for the LAN connection that I've setup.

It still shows that I'm being firewalled.

SWANG77
2008-05-10, 11:40 AM
i'm having a similar issue that's only come up with my most recent download.

i have never had a firewall issue since i disable both norton and windows xp firewalls when i download. i'm using bittornado (same client i've always used), windows xp (with firewall disabled) and no router at all (connected directly through my verizon dsl modem). and yet, i'm firewalled.

this has only happened recently and never in the past. i'm going to try to determine what the problem might be, but if anyone can eliminate some possibilities for me, that might save me some trouble and time. thanks...

SWANG77
2008-05-10, 12:23 PM
update: my modem is a westell 2200. sorry for being unclear on that earlier.

i used the links after selecting all the appropriate info on portfoward.com. i reconfigured my bittornado and my modem, and yet, ttd still indicates that i am firewalled.

SWANG77
2008-05-10, 12:51 PM
update to the update: issue resolved, light is green.

thank you...:)

dmonte
2008-05-13, 11:26 AM
I am still Firewalled, and I've done all that I can do. I'm not sure why I'm still Firewalled. I have followed all the instructions to the letter. This is very frustrating, but I'm not sure what else I can do.

U2Lynne
2008-05-13, 11:44 AM
I am still Firewalled, and I've done all that I can do. I'm not sure why I'm still Firewalled. I have followed all the instructions to the letter. This is very frustrating, but I'm not sure what else I can do.
So, you forwarded port 61374 to a static local IP, 192.168.1.xxx, and you are still showing up as firewalled? Don't forget that if you play with your port settings, you will still show up firewalled here until you stop your torrents and then start them. I would not use TTD though to figure out if your forwarding worked, I would go to canyouseeme.org to see if it worked.

dmonte
2008-05-16, 10:56 AM
So, you forwarded port 61374 to a static local IP, 192.168.1.xxx, and you are still showing up as firewalled? Don't forget that if you play with your port settings, you will still show up firewalled here until you stop your torrents and then start them. I would not use TTD though to figure out if your forwarding worked, I would go to canyouseeme.org to see if it worked.

Correct. I just repeated the process this morning to be sure:
- I closed BitTorrent and stopped all my torrents
- I disabled my wireless connection so that I'm only connecting via Ethernet through the router and then the DSL modem.
- I established a static IP address, which is working properly
- I allowed access to port 61374 through my AT&T Firewall
- I forwarded port 61374 on the newly established static IP address in my router, following the instructions at PortForward.com for my router model.

When I check at canyouseeme.org, I get the following message:
Error: I could not see your service on [my external IP address] on port (61374)
Reason: Connection timed out

Then I opened BT again, and TDD is still showing me as being Firewalled. So now what? Could there be a conflict between my router and the DSL modem? Does the DSL modem also act as a router ... and therefore I would need to forward the port on it as well? If so, I would have no idea how to do that.

direwolf-pgh
2008-05-16, 11:34 AM
it reads as though you only allow port 61374 (internet) > port 61374 (computer)

your config should be: All/Any Port (internet) > port 61374 (computer)

hope this helps

dmonte
2008-05-16, 11:57 AM
it reads as though you only allow port 61374 (internet) > port 61374 (computer)

your config should be: All/Any Port (internet) > port 61374 (computer)

hope this helps


Thanks ... actually I got on the phone with my DSL tech support and forwarded the ports on my DSL modem. Now everything seems to be working properly. www.canyouseeme.org can see me, and TDD shows that I am no longer firewalled.

So it seems the issue was that I need to forward the ports in my router as well as the DSL modem.

Thanks.