PDA

View Full Version : Upload Stuck - 18 Connections Waiting @38%


JohnnyThunder
2007-11-05, 11:36 AM
Well yesterday's problem was the "Bad data from tracker" and we got around that and started uploading in a big way. Last night, I noticed as everyone was hitting the 38% mark the upload speed started dwindling down from an average of 70-80kbps to 8-9kps. Then, I watched in horror at around 11:00pm or so PST as it literally drained down to 0kps. I stopped and restarted the Client (ABC). I rebooted WinXP Pro. Nothing changed, so I went back to bed hoping it would resolve.

This morning I realized it had not. I checked my firewall monitor to see if I had some sort of denial of service attack going on myself, and nothing unusual except I did see a report of a "low risk attack from TTD". The detals were listed as thus:

***begin paste***
IP Address Attacker Domain High Risk Med Risk Low Risk

69.61.67.252 ttd1.thetradersden.org 0 0 1

View Attack Details Details
Internet Domain: ttd1.thetradersden.org
Internet Address: 69.61.67.252
Today 1
This Week 1
Total Attacks Blocked 1

High Risk 0

Med Risk 0

Low Risk 1

TCP Port Scan Detected, Packet Dropped 1
***end paste***

At this point, I shut everything down for five minutes including the DSL modem and then brought everything back on-line. For a brief period, the upload was back on. It moved quickly up to the 60-70kpbs range and then began to fall back down to nothing within a couple of minutes if not less (I did not see the fall - - I actually thought I had fixed it and then came back to look two minutes later and found the UL speed at 0.0 again).

So, once again the bit torrent gremlins have stumped me. Any help and sage advice would be appreciated by me and the folks who are trying to complete the upload.

Thanks,

Jon

Paul56
2007-11-05, 11:59 AM
The Firewall should be turned off (Control Panel>Windows Firewall).
Add TD ip to the exception list in any adware/spyware programs running and to the Firewall.

U2Lynne
2007-11-05, 12:02 PM
First off, I'm not a PC person (I'm a Mac person), but it sounds to me like your firewall software is blocking your bittorrent activity. When you torrent, the first thing that happens is your client contacts our tracker. Then, the tracker helps you connect to other peers. I think once you are connected to other peers, the other peers clients help connect you to others. All seems fine for you at that point. But, every so often (usually about 40 minutes), your client makes contact back with our tracker in order to update your stats. It sounds like that is when the problem is occurring cuz our tracker also sends back some info (updated seeds/leechers info). I think you need to tell your firewall that it needs to allow incoming and outgoing connections from your bittorrent client.


edit: It looks like Paul beat me to it and said it in a much more concise manner. :)

JohnnyThunder
2007-11-05, 03:26 PM
Well folks, I've tried all of the above and then some. In every permutation imaginable. I have redownloaded the torrent file several times, and stuck in different folders with varying levels of success, usually the root I have for all TradersDen stuff or the specific root for this show works the best. I have turned off Windows Firewall, even though it has been configured for the port used by the bit torrent client and the ports used to communicate with TTD 6881-6889.....I have set the Firewall that is built into the DSL modem to allow TCP port scanning (it already has been set to allow the ABC bit torrent client at the port it uses) and after all - - I don't show up as firewalled in my stats here. I have powered up and down, and restarted the bit torrent client and so on and so forth, ad nausium, including stopping all other software running down to bare bones on the PC. I haven't had a problem downloading - well, I shouldn't say that as it has been a little quirky, but I have managed. But this issue is more than a quirk.

The best I've seen is I'll think I've fixed it, and either walk away, or do some other stuff on the computer and then come back and find the upload rate has hit 0.0 again......withing 10 minutes of thinking all is well. Yesterday, all was well for the first three hours or so.

Is there a bit torrent hex on this upload, or is there something I am still missing in my first attempt at sharing something here? I and the anytwhere between 18 and 22 folks that have been trying to connect would love to know.

Appreciate any help.

Thanks,

Jon

direwolf-pgh
2007-11-05, 03:49 PM
enable encryption (in your torrent client)

you sound like a comcast customer to me (upload issues)

U2Lynne
2007-11-05, 03:57 PM
enable encryption (in your torrent client)
That was gonna be my next suggestion. :cool:

JohnnyThunder
2007-11-05, 04:32 PM
Not Comcast, but Qwest......Comcast would be faster. I am out in the boonies where cable doesn't even get to us. The phone company only recently fianlly got there switching equipment upgraded to the point where 100mps DSL was possible. For years I had been a 18kps dial-up sufferer......

Anyway, I looked for an encryption setting in ABC and there is nothing intuitive. The only thing close was a section under Preferences, Disk, that addressed file locking, and it was turned on. I also noted that there was some goofy limiting stuff turned on, buried in the preferences as default. I turned it off, or set it to up load 100 files and whaddayya know.....all of a sudden I am actually uploading data again (and I should not have said that out loud). It is struggling at around 16-20kps......better than nothing.

I am noting that I seem to be the only one using ABC as a client. Should that be a hint?

I am going to tip toe away from this thing and see if it continues.

Thanks,

Jon

Paul56
2007-11-05, 09:31 PM
JT~ you are still not showing up as a seeder.

Are the ports being used by another program?

There may be no need for port forwarding since an ADSL modem is a Point to Point connection. 1 PC (or router) connected to the modem. If you have a public address then the address on the site http://www.whatismyip.com/ is the same as your computer, then you don't need port forwarding. The only blocking point can be a firewall installed on your PC.

If the address is different then look at http://portforward.com/routers.htm
pick out your modem/router and your application (ABC) and follow. Also I've read that ISP's sometimes try to block ports below 50,000. I use port 52371 with utorrent. I tried Azureus and liked it, however I find utorrent better with the PC.

You mentioned that you are using ports 6881-6889, most of the torrent applications call for only one port set-up with both TCP/UDP checked.

Unless your ADSL provider or the ADSL manufacture says otherwise, you can access your ADSL modem/router by going to 192.168.1.1 or 192.168.0.1. You will need administrator's username and password. It varies by brands but the default is admin/password, respectively. (Comcast comes into my router, reboots and removes my port forwarding almost weekly)

Also, you can go to Control Panel>Windows Firewall>exceptions> and list your open ports so your computer knows where to send the traffic. For Example add the following:
[add program] ABC - path C:\Program Files\ABC.exe (location of your program)
[add port] ABC - port 52371 (check TCP)
[add port] ABC - port 52371 (check UDP)

Everyone here is willing to help you here, if you get stuck send us the make of your modem. Good luck!

JohnnyThunder
2007-11-06, 12:32 PM
Paul,

The modem is a Qwest 2701HG-D - - I followed the set-up instructions for the Qwest 2700HG in the Port Forward site, since it was the only listed that came close. The instructions for ABC seemed truncacted, but I followed them per print at first. I also followed them per print for Azureus (but have not added Azureus into the active slot yet). Noting that Azureus had some extra steps (Azur1, Azur2, etc.) I patterend that for ABC and set ABC up accordingly and things have not changed.

Right now I have ABC1 set for 6881 ABC2 set for 59877 TCP and ABC3 set for 59877 UDP and I am not getting any more joy than before. I had Windows firewall similarly configured, but for now it is turned off.....still, it is poking (the upload) along at 14-20kps and only one individual (IP 85.127.142.142) is showing as receiving - - - all others are stuck.

I also rebooted with MSCONFIG and absoluted paired startup programs down to a minimum so I don't think I have any other software conflicts running.

I can call Qwest tech support unless you guys think (see my post on the upload) that's a bad idea. I've got to run......back in a few hours. In the meantime, I will leave ABC up and let it upload at whatever speed it can muster.

Thanks for the help.

Jon

direwolf-pgh
2007-11-06, 01:00 PM
according to your config mentioned,
only someone on port 6881 & 59877 could possibly reach you.

you want ALL (public) ports available to your one internal port (59877).

U2Lynne
2007-11-06, 02:06 PM
Jon, a big problem right now is that you connected to the torrent you uploaded, however you are connected as a leecher, not a seeder. You probably want to take a look at this: http://www.thetradersden.org/forums/faq.php?faq=bittorrent#faq_wrong_folder

JohnnyThunder
2007-11-06, 04:26 PM
OK guys, I really appreciate the help, but please do bear with me - -;

I did download Azureus, but am not ready to switch over in mid-stream - - I have enough things screwed up as it is (I think) - I think I followed the gist of Lynn's comment's though on the download folder; I had moved the torrent file to the folder where the files were, and not the default download folder (actually, throughout trying to solve the mess yesterday I had it in both places and neither one seeemed to make a difference, but for now, it is back in the place I created the torrrent file in).

On Paul's comment about the port settings, I'm absolutely in a fog as to how to set the ports so that "you want ALL (public) ports available to your one internal port (59877)."

For now, I have re-downloaded the torrent, moved it back to the original folder where it was created, and let's see if that makes any difference.

Sorry to be so dense. I will get it one of these days............

Jon

JohnnyThunder
2007-11-06, 09:37 PM
I posted this message to the upload/torrent forum on the Kinks 1993-10-06 Second Coming thread:

Folks,

I bagged ABC and set-up Azureus. I have checked and rechecked firewall and port forward settings; all report back as they should be. After installing Azureus, and correcting the "I want to download instead of upload issue" as described in the link U2Lynne sent me (Thank you Lynne) at http://www.thetradersden.org/forums/faq.php?faq=bittorrent#faq_wrong_folder I actually got some rip-roaring up-load speeds and got the green light in Azureus. I'm not sure that I was showing up as a seeder correctly on the Peer's list on the upload/torrent page here, but my rate of progress showed 98.9% instead of 38.89 (along with everybody else) and a couple of folks on the list actually made some upward progress beyond 38.89%. However, within minutes, Azureus reported a corrupt file issue and stated it was re-downloading the show and went from upload to download and my % completion went right back to 38%. I went through this three times, and Azureus reported the same issue with piece or part 45 of the upload.

What struck me, is that everybody's upload died at 38.89% when I was trying the first time. The progress I made after that, was only when someone new joined the peer group and they got data until they reached 38.89% and then they too stopped receiving data.

I am thinking that something is corrupt and that's where the problem is. My not showing as a seeder may be another issue, but you were all getting good rates of data until the 38.89 mark. It may be time to pull the post, dump the files on my end and I will re-build everything from scratch and try once again.

I will post this on the Technobabble forum as well, but because all Azureus wants to do right now is redownload what I have already uploaded, I am doing to keep the client off-line until we figure out the next step.

Thanks again for your patience.

Jon

Paul56
2007-11-06, 10:17 PM
For now, I have re-downloaded the torrent, moved it back to the original folder where it was created, and let's see if that makes any difference.

Jon


JT, when you double-click on the torrent file the Azureus window "Open Torrents" should open, the "Location to save data;" should be the folder where you have the show, browse to the folder, click OK. The torrent should open in Azureus and do a check for a few seconds then begin seeding. The actual torrent file should not be in this folder. Hope this helps!