View Full Version : please help me U2Lynne

2007-09-19, 06:20 AM
I am running openSuSE Linux 10.2. I have been over Port Forward in a way I think is fairly thoroughly. I can find only Windows advice. I am at a loss to find anything non-Windows there

I am root. I have Wireshark, and access to all of the information.
I just moved into a new house in a new state. I've never had a problem before.
I can almost always figure out why I am firewalled and fix it, but not this time.
The friends I moved in with are using an ancient Linksys 5 port router, model NH1005 (yeah, old). We are also on Hughes Net, because it's in nowhereville, but it's supposed to be 1000kb/s. I'm getting 45kb/s on http and ftp, and a max of 3kb/s on bittorrent download, with no upload speed at all.

I am using Azureus advanced classic My Azurues ports I handpicked at random, and my SuSE firewall is wide open for them. I do know the router, previously on a hardwired cable modem, could transfer at at least 5mb/s, up and down.

Have you heard about problems with high speed satellite?
Is there a Linux section at port forward I am too slow to find?
(I have been searching it, but it takes like 3 minutes to load a page)
Please help me. This is horrible.
I thought 75kb/s upload was horribly slow, but apparently I was on top of the world.

I tried at opensuse forums, but sometimes they want you to help yourself.
Thank you for your time.

2007-09-19, 10:29 AM
You will get more help if you put "Help with port forwarding on linux" than by just putting my name in the title. I'm not a linux user, so I'm really not going to be much help at all.

First, have you checked on canyouseeme.org to see if you have successfully opened your ports? It sounds like you have, but you should just verify it. Also, you should do a speed test and see what sorts of speeds you are really getting.

Have you looked at http://www.portforward.com/guides.htm? Your router is not listed there, so you won't get any help in that area. You might be able to get help in their forums.

2007-09-19, 01:26 PM
Canyouseeme.org timed out repeatedly, at least at five a.m. Azureus switches back and forth between open and firewalled, but that doesn't affect my speeds, which is crazy. I did do a speed test, and dial-up blows this out of the water.

I knew it was a long shot that you might be into code. The problem is not that people don't want to help, it's that without being at my physical location they can't get an accurate idea of what's going on. I can see now I'm going to be poring over packet data, configuration scripts and router modules until I'm blue in the face. I called our ISP to get info on the modem and the dish so I could put it into my system, and they had no idea what opensuse is. It sounded as though they thought I was deranged. :)

Thanks for your time. I will definitely be into the Portforward forum. I hadn't had time to think of that yet, so I appreciate the suggestion.
Take care.

2007-09-19, 01:52 PM
sounds like a lot of effort just to open a port
check your iptables (firewall) and create a rule to open you're torrent port.

slow speeds - thats a provider issue. and get a new hub for $35 - old hubs dont always talk with new NIC cards properly.

2007-09-19, 05:16 PM
Yeah, the new hub is definitely something that needs to be done.
That is excellent advice. I just need to find the time to drive the 50 miles to a big town. Hell, that may solve the problem.

I already did everything for localhost, ip address, pinging, ethernet configuration, router configuration, and I attempted repeatedly to add the ISP manually. We do have Yast2 in opensuse 10.2, and it normally just handles problems like this with a little coaxing.

Dude, I do not want to start going into the really small data, but if I have to I will. There is no other high speed ISP for this area. The only reason I talked about going into the tiny details is because I have done every single other thing. I really do appreciate your input though.

I'm one of the guys who worked with ALSA to hack the snd-hda-intel based hidef soundcard module. It took me 4 months to get my bleeding edge soundcard to work. I don't want to go through something like that again, and, as you say, this just doesn't seem worth it. But I like uploading... a lot.

2007-09-20, 10:26 PM
Thank you again for your excellent advice on the router direwolf. I got a really nice one. I am very happy with it. It did not fix the problem.

I will not be able to fix this problem, no matter how much time I spend changing numbers and opening ports, or hacking the hardware in my house (which might take months anyway). It's nothing to do with my home, or my computer, or my router.
Don't be stupid like me. Find a functioning internet connection, if you don't have one (like I didn't when we got it), and do some research first.
http://www.tiny.cc/YU5rc - it's an old thread, but it will give you a perfect idea of what will happen. If you can't get a reverse DNS entry it's fairly fake. We will be taking immediate action to terminate the contract. I could get a better connection pedalling a bicycle to uplink.

I just wanted to post in case this could help keep somebody else from going through this.
Thank you.
Also, thank you Direwolf for all the music. I could only dream of reaching your level.

2007-09-22, 02:19 PM
I asked for help because I am not that verbose in networking. I am all about sound.
I have a little ego problem sometimes, which is obnoxious, and I am sorry it sounded that way.
I did figure it out. It wasn't Hughes Net, and it wasn't me.
I had a rootkit, which I imported to this rather largish network here.
It was sending out 10,000 very bad emails a day, while totally denying this network any service at all, basically.
It is in fact quite a high speed connection.
I hope to be uploading some of the 750 gigs of shows I got from everywhere else very soon, after I get permissions and verify they aren't duplicates. It's far past time I did that here.

Thank you all for your time and your patience

2007-09-22, 02:21 PM
I'm glad to hear you figured it out. I'm also glad you posted here about what the problem was since that helps others when they do a search here.


2007-09-23, 05:08 PM
I did have a rootkit. I was in the middle of contacting Charlie Miller about sharing some of the higher quality GD here, when my connection went out again, this time apparently for good (at upload speeds anyway). I may get an affirmative from him, but it would be pointless to upload at 575 bytes per second. Not to mention, I only wanted to share a few of the very best of those shows, and all my other efforts to contact people are dead in the water.

I also have several hundred gigs of level 10 ogg (the only thing you lose is silence -- not like MP3), but that is, I am sure, not worth mentioning. I mean, it isn't lossless, from a semantic perspective.

There is some sort of satellite uplink permissions issue here at my end. I think I can trick it, because I did this morning, but in the middle of an upload... not so much.

I certainly feel stupid,
or at least look it.
If I have to move again to get a landline I will.
Does this sound as tedious as I feel it is?
Thank you again,
I appreciate TTD.