View Full Version : NAT Problem Seeding - Comcast/Linksys

2007-09-17, 05:21 PM
I'm trying very hard to seed my four torrents. I started seeding yesterday and things were moving along fine, although Azureus lights were mostly in the yellow and red. I seem to now have a NAT problem.

I have gone through the setup again, FAQ and Port Forward with some errors. I'm using a Linksys WRT54G router, Comcast as the ISP.

I updated my Network Connection to static ip I updated the router with Azur1 Port Forward 6881 to 6881 and Azur2 Port Forward 59999 to 59999, and changed the port in Azureus to 59999. My external ip with Comcast is a different ip address. When I run a test within Azureus or with CanUSeeMe it's only finding the (external Comcast ip):59999 The system works in the Yellow at ip but is red and having timeouts when the ip is set at as suggested in Port Forwarding.

I have several peers at 99.7% on a torrent and can't seem to get it to finish.

Thank you in advance for any help in this matter. I think your community is great by the way.


2007-09-17, 07:50 PM
Check out this thread:


Lots of people have problems uploading after completing with Comcast because Comcast uses a company called Sandvine to prevent them from uploading after they complete. If you install the free firewall and follow the instructions you should be able to upload just fine.

You only have to forward one port for Azureus.

2007-09-17, 09:30 PM
Thanks Tubular, I tried it but still having the same issues.

I've installed the Redhatcat firewall and researched the issue and made changes, I found out the the Linksys router works better with a different TCP (59999) and UDP (60000) port which I have done. I have received one green light out of the five, most of the time they are yellow or red. I have worked on this for hours.

I also getting the Connection Error limit exceeded..You may only download 5 shows at a time. I don't know why I have the 4 seeds and one download that has been going for 2 days.

I do not want to disappoint any of the peers waiting for the seed. If you have any ideas I'll listen. Thanks again.

2007-09-17, 10:24 PM
On the one where you are at 99.7%, did you have a text file open from the torrent when you started seeding and closed it and saved the changes? If so then it will be modified and you won't be able to complete seeding. The audio files might be OK though. Until you get it fixed or start a new torrent, you could tell the people waiting to test their audio files and see if they verify. Don't worry, someone will help you get the problem sorted out. :wave:

2007-09-17, 10:51 PM
Paul, part of your problem is that you are showing up as leechers on the shows and not as a seeder. You need to stop the torrent, remove it, make sure your options in Azureus is set to ask you where to save the files, then start the torrent file again and when it asks where to save the file, point it to the same folder you pointed to when you made the torrent. You need to fix that issue first before worrying about the firewall issue. Since you are listed as a leecher, that is why you are getting that connection limit error when you try to download a couple of shows and also seed your shows.

Once you show up as a seeder in the list, then make sure you have the same port listed in Azureus as you do in the router (59999). Then you need to pick your static local IP - and make sure that is the one you have listed on your computer and in your router.

Also, depending on what your connection is like, it is usually best to only seed one or two shows at a time and to try to put off downloading a show until after you have a couple of completes on the show you are seeding.

2007-09-18, 12:07 AM

Thanks for taking care of me on this, I'm really sorry to bother you.

I did everything you mentioned and re-read the info. I now have the torrents listed as Seeding. They have a blue light at this time. The tracker status has the Connection Error (Invalid passkey).

Thanks again for walking me through this.


2007-09-18, 01:02 AM
If you have the Invalid Passkey error, then you are using the original torrent you made, instead of downloading the one from the thread. So, do the steps again: stop the torrent, remove it, make sure your options in Azureus is set to ask you where to save the files, then download the torrent from the thread and make note of where it is, then start the downloaded torrent file and when it asks where to save the file, point it to the same folder you pointed to when you made the torrent.

2007-09-18, 01:43 AM
Lynne, Got it. Seeding 3 torrents. The problem was not having the box unchecked then not selecting the original folder. Got them going now. Thank you very much for all of your help. Paul

2007-09-18, 10:26 AM
Yep, looks great!

It looks like this one is fully seeded now, so you can probably drop off of it and just seed the other two - Grateful Dead 1973-11-17 Pauly Pavillion, UCLA (SHN)

(Just a suggestion, you can do what you want! :D )

2007-09-18, 02:38 PM
Alright! Thank you very much again Lynne; and thank you to BeerLover, Tubular, and maalmoma for your help along the way. I'm seeding my torrents and the downloaded torrents.

Other issue: I still cannot get any green smiles, after I'm fully seeded I'll try and change the port forwarding # on the router, Windows firewall and in the redcathat software and see if I can get to green. I do seem to be running over 40 kb/s for the uploads. CuCme comes back with the Comcast ip address not my local router>computer ip:port. Thanks again for all of your assistance.