PDA

View Full Version : Firewalled - what now?


PL44
2007-05-29, 05:02 AM
Picking up a thread about how to open ports, I'd like to ask for some help how to do that.
Before starting with it, I'd also like to mention that it had cost me quite some time and nerves to set up the damn router and airport settings until my Mac worked properly, so I definetely don't want to do everything all over again.

What I'm looking for is an easy way to temporarily open the firewall.
My hardware is the following:

Mac Pro w airport
DSL wireless router: D-Link DI524

Tell me what other infos you need to help and I see what I can do.
Pl44

ArchivalAudio
2007-05-29, 08:44 AM
well
have you set up a static ip address?

did you go here
http://www.portforward.com/english/routers/port_forwarding/Apple/AirPortExtreame/default.htm

what torrent client do you use?
I have been using Azureus if not try it.
some other info here
http://azureuswiki.com/index.php/Port_forwarding

gotta get to work...
more later

U2Lynne
2007-05-29, 10:32 AM
What does it say under System Preferences > Network, and then select the Green Lit configuration and hit Configure. Up will come a page with your settings... under TCP/IP, what do you have selected for Configure Ipv4? I use Manually (and then put in an IP Address in the next slot), what does yours say? That will help us go to the next spot.

PL44
2007-05-29, 02:11 PM
What does it say under System Preferences > Network, and then select the Green Lit configuration and hit Configure. Up will come a page with your settings... under TCP/IP, what do you have selected for Configure Ipv4? I use Manually (and then put in an IP Address in the next slot), what does yours say? That will help us go to the next spot.

Ipv4: DHCP

ArchivalAudio
2007-05-29, 07:55 PM
set up
you prefs manually

in system prefs use
Airport
then
in TCP/IP
configure IPv4
choose manually
could could choose
10.0.1.201 as you static IP
subnet mask to:
255.255.255.0

and set your Airport to : 10.0.1.1
as well as the DNS servers to 10.0.1.1

see here and follow this:
http://www.portforward.com/networking/static-Mac10.4.htm


set your airport to (radio button) Share asingle IP address (using DCHP and NAT)
select
Use 10.0.1.1 addressing

follow the port forwarding tips
and remember to forward your ports in airport
under port mapping tab of configuration mode
a port choice
could be
Public Port: 6883 Private IP Address: 10.0.1.201 private port : 6883

try all that?

follow the Port forwading instructions...
it should work
you may have to restart all
your airport your DSL modem and your computer, and or Azureus or other torrent client
so does that help?

I hope
good luck

PL44
2007-05-30, 02:58 AM
set up
you prefs manually

in system prefs use
Airport
then
in TCP/IP
configure IPv4
choose manually
could could choose
10.0.1.201 as you static IP
subnet mask to:
255.255.255.0

and set your Airport to : 10.0.1.1
as well as the DNS servers to 10.0.1.1

see here and follow this:
http://www.portforward.com/networking/static-Mac10.4.htm


set your airport to (radio button) Share asingle IP address (using DCHP and NAT)
select
Use 10.0.1.1 addressing

follow the port forwarding tips
and remember to forward your ports in airport
under port mapping tab of configuration mode
a port choice
could be
Public Port: 6883 Private IP Address: 10.0.1.201 private port : 6883

try all that?

follow the Port forwading instructions...
it should work
you may have to restart all
your airport your DSL modem and your computer, and or Azureus or other torrent client
so does that help?

I hope
good luck

Well, yes...I will try. Will create an alternative configuration, so that I can return if this leads me nowhere. Will take some days - much work to do. I'll let you know.

U2Lynne
2007-05-30, 10:37 AM
If that doesn't work for you, let me know cuz I have a couple more questions for you (just as I asked about what you had in Configure IPv4, I would have asked what you have down for 'Router' and 'Subnet Mask' on that same page. I have '192.168.1.1' down for router, but it seems ArchivalAudio has '10.0.1.1', so I would have been suggesting different IPs to be putting into those fields than he did.) But yes, as you said, make it an alternative configuration so you can easily change back if need be.

ArchivalAudio
2007-05-31, 01:07 AM
well
my thought
was that it worked for me
to set up a static IP
which is suggested
at (again)
here
http://www.portforward.com/networking/static-Mac10.4.htm

and if you follow the Melted M&M
example
fromm here
http://www.portforward.com/english/routers/port_forwarding/Apple/AirPortExtreame/default.htm
they use
the
10.0.1.1 Addressing

thats wwhat did it for me

also
picking a 5 digit port to forward

at first I was ok with 6883 but then it was blocked

check here
http://azureuswiki.com/index.php/PortIsBlacklisted


any way
I am sure I found other info whan I was setting my airport up

it was a bit frustrating
and I thought I had it done for a while
but didn't

my Nat is ok

I think if you use the 192.168......... addressing
like Lynne suggests, it may work
but
since the example at portforwarding is right
and they uses the 10.0.1.1
Static IP scheme

seems to work here...

also
you need to go the pref pannel

and in the Shareing file folder icon

you need to "forward" the ports you want open

under firewall tab
I have added


the port
Azereus (54210)
which is the port I am forwarding

also since I am using 10.0.1.201 addressing
I see this under the Services tab of the Sharing Pref pannel...

Other Macintosh users can access your computer at afp://10.0.1.201/ or browse for "XXXX_ XXXX _Computer" by choosing Network from the Go menu in the Finder.


because I have the fire wall on
but Personal File sharing
enabled
including FTP

does that make any sense?

ArchivalAudio
2007-05-31, 01:14 AM
oops

I also forgot
this



if you want to chack to see if your ports are actually opened
go here
http://www.canyouseeme.org/


and to test your speed
(Preferably without any torrents running and only this one web browser window
open)
go
here

http://www.speakeasy.net/speedtest/

and choose
the server location closest to you

peace
and good luck

ArchivalAudio
2008-09-19, 02:03 AM
Damn...
My iBook
died
I have resureected it
and set every thing the way I had it before
but
Now
I am firewalled!

I lost all of my Azureus , an dthe associated .torrent files


I am so confused
I have went thru changin ports via the prot forwarding
Like I have said above
but still
I appear as fire walled
totally sucks!

any suggestions
I even changed my port from54210 to54211
to see if that helped
but
it did not

I feel like a sucker

help!

peace be with us
-- Ian

U2Lynne
2008-09-19, 09:51 AM
Verify your static IP in System Preferences > Network It should be something like 192.168.1.xxx . Then log in to your router and verify that the ports are being forwarded to that IP. Also, check if your Mac Firewall is on or not.

ArchivalAudio
2008-09-22, 09:03 PM
well
I think I fixed it
at least in Azureus

no more firewall

I needed to set my Network
Pref panel
manually
IP Address to : 10.0.1.201
which is the "scheme" I am using
the 10.0.1.1 addressing for my router

ther for I need to forward
10.0.1.201
and I have opened those ports
and yes I use
the Apple Firewall software

I hope I can keep this going

thanx
-- Ian

U2Lynne
2008-09-22, 11:09 PM
Glad you got it to work. :thumbsup

ArchivalAudio
2008-09-23, 01:58 AM
also
you need to go the pref pannel

also since I am using 10.0.1.201 addressing
I see this under the Services tab of the Sharing Pref pannel...



^^^^^^^^^^^^^^ That's what I forgot to set up correctly
10.0.1.201
in the network prefs

I am totally non longer fire walled
and it is varified with
http://www.canyouseeme.org/

Yeah!


-- Ian

ArchivalAudio
2008-09-23, 02:00 AM
Glad you got it to work. :thumbsup

thanx
U2Lynne
me too!
may be even more than you ;)

glad I am back up n running
just lost all of my old pervious torrents that I had that were active or Queued :(

thing are looking up now
thanx again
-- Ian