PDA

View Full Version : Port Forwarding driving me mad!


dibs
2006-03-09, 01:51 AM
Ok, I used to know how to do this like 3 years ago, but for some reason now, after reading every guide on the net, I can't get it to work. Here it goes:

OS: Windows XP Media Center Edition 2005
Router: Linksys BEFW11S4 with wireless turned off
Client: Newest version of Azureus
Port: 60000

Windows firewall disabled, ports forwarded from 60000 to 60000, TCP and UDP both eneabled. Address I'm forwarding to is xxxxxxx. I put in my local IP, subnet mask and DNS server number into the properties of my connection and turned DHCP off in the router. What am I missing? Big thanks for anyone that can help.

TheMamba
2006-03-09, 04:57 AM
Did you go to www.portforward.com?


Double check that your BT client is set up to use port 60000 too.

dibs
2006-03-09, 01:10 PM
I did, and it is. When I bring up the NAT/Firewall test, it says 60000, and then when I test it it says "NAT error". I also have Norton anti-virus. Do I have to completely disable that?
Thanks

feralicious
2006-03-09, 02:02 PM
No, you shouldn't have to turn off any AV program.

Do you need to specify which program uses the port in the firewall software so that both the BT client and the firewall are set for the same port, and the firewall knows that BT is allowed to use that port.

dibs
2006-03-09, 02:43 PM
If you mean in the linsys router setup, then yes, I think I did that. this is what my port forwarding line looks like:

Azur1 60000 to 60000 TCP (checked) UPP (checked) xxxxxxx Enable (checked)

dibs
2006-03-09, 02:49 PM
OK. I found a section in the router settings that says "static routing" It has the following options:

Destination LAN IP:
Subnet:
Gateway:
Hop count:

They seem to be the same options as in the properties of my connection. I'm putting these in and trying it. One question. The IP address I forward my port to has to be different than the "destination IP address" right?

jayroch
2006-03-09, 05:10 PM
Sounds like that may be your issue. You need to make sure that your router always gives your compter the same local ip address. It's in those static Ip settings somewhere. You can also set your router to only assign one or a few local ip addresses and forward all of them. I only have my computer and an xbox conected to my router so I have it set to only allow 2 addresses and I forward them both. I'm not sure if thats the best way to do it but it works for me. And remember it's always a good idea to do a restart after you mess with the settings.
Hope this helps.

dibs
2006-03-09, 05:33 PM
Ok, I think I'm almost there. One more question. Should the address I put in my port forwarding line be the same one as my local IP for my computer? Or is that where I put the different last 3 digits ie. 192.168.xxx. I also have an xbox 360 hooked up to my router, but I'll deal with forwarding that at a later time.

Maybe this will be easier. Here is my ipconfig info:
IP Address: xxxxxxxx
mask: xxxxxxxxxxxxxx
Gateway:xxxxxxxxxxxxxxxx
Server: xxxxxxxxxxxxxxxxxxxx

What do I put in as the "destination IP, and what do I put as my port forwarding IP? Also, I put the exact same info as above into the properties window of my internet connection on my computer just like the static IP instructions say from portforwarding.com. Thanks to you guys for trying to help. Sorry I'm so networking stupid.

thisistoto
2006-03-09, 06:14 PM
Do you have UPnP DISabled? (On both Azerues and your router?)

jayroch
2006-03-09, 07:05 PM
From what it says in the torrent your downloadind your ip address is this 68.75.180.xxx(60000) not this xxxxxxxxxxxxxxxxxx. The first is your ip as seen from the internet, and the second maybe the local ip that your router has set to your computer for your home network. If you are doing the static ip option or maybe you already did and thats the ip you used then that is the ip you forward.

I dont belive you have to forward an xbox I think it uses another protocal.
what I was saying before was just a way to keep your router from changing your local ip every time it restarts to something that is not forwarded for your computer. disregaurd it if you set up a static local ip address.

I personaly have UPnP disabled as I think it is a posible security risk. UPnP is disigned to automaticaly forward ports for programs that are compatable with it.

Hey I'm self tought too so don't feel bad just try and help others once you get the hang of it. And besides every router and computer is different, even the brightest people get confused at this stuff.

Here's some links that may be handy

http://utils.vninformatics.com/ipchecker/

http://en.wikipedia.org/wiki/List_of_well-known_ports_(computing)

http://wiki.etree.org/index.php?page=AcronymGlossary

http://teoulas.myname.gr/

feralicious
2006-03-09, 08:59 PM
dibs you should have a mod edit out your ips. Not a good idea to post that.

jayroch
2006-03-09, 09:29 PM
dibs you should have a mod edit out your ips. Not a good idea to post that.

the one ip with the xxx is listed for everyone that downloads a torrent under the peer list.The other one is a standard linksys ip that anyone that owns a linksys router knows. Unless someone can guess those three numbers nobody knows his actual ip. This is standard stuff available to everybody.

dibs
2006-03-10, 03:14 PM
After about 15 hours of trial and error and talking to numerous people on the net, I finally figured out what was wrong. My dsl modem had a firewall active. I just let Azureus be an exception in the modem settings, and it opened right up.

Thanks to all for the help. They should really include that step in these tutorials instead of just talking about the router. I didn't realize a modem was considered a router that can have it's own firewall. I had to find out from somebody in Azureus chat support.