View Full Version : IDE Device Failed

2006-02-23, 09:46 PM
I have recently begun to have problems with my CXR700e (CDRW). I have searched on Dell and Google and have not gotten any guidance. Perhaps there is an answer on TTD. I seem to be having some problems with my CDRW. I can no longer burn greater than 2x. I can successfully burn with EAC or Easy CD-DA Extractor, as long as it is 2x. At 4x I get errors and the burn stops.

I have updated my drivers and have run the Dell DIAGNOSTICS CD. I run an extensive test of the drive and get the error very early in the test.

Error Message:
"IDE device failed"
"no audio output"

The problems are that it is quite buggy and seems to have problems with "disc-at-once" when running Nero. I still can burn but there are more problems. I have been searching for help on this error and can not find any solutions.

Thanks in advance,

Windows Me
Inspiron 8000
Sony CXR700e (1.4u)

2006-02-23, 10:30 PM

I once had a very similiar problem as yours, except it had to do with burning DVDs. After a long time back and forth with Gateway support, I eventually fixed the problem myself. It turned out to be an issue with DMA mode, which allows for a direct data flow between your computer's processor, and the burner itself. If the burner receives an error in the data flow, it can set the mode back to PIO mode, which can cause such speed issues, and the IDE issue. The DMA mode must be set on your IDE device, because the burner is connected to the motherboard through this vitual port. To make sure DMA is turned on, do the following:

1.) Right Click on My Computer
2.) Click Properties
3.) Click the Hardware Tab, and then Device Manager
4.) Click the plus sign next to "IDE ATA..."
5.) Right click on either the primary or secondary IDE controllers and hit "properties". Here it really depends on what IDE channel If you have one marked "secondary IDE...", then I'm 90% sure that it is connected to that one.
6.) Now that your in the Properties tab of the either IDE controller, click on "Advanced Settings"
7.) Look at what "Current Transfer Mode" says. If it says PIO, then you need to go up to the box above it, and select "DMA if available". Do that for both device 0 and device 1.
8.) Restart your computer, and follow that same process again, but....this time of course don't change any settings, just look to make sure the "Current Transfer Mode" is set to "DMA Ultra Mode 2", or Mode 5, depending upon the machine.

I hope that helps. Post back with the results.

2006-02-24, 08:36 PM
Local Hero,
I really appreciate the help. In Windows ME the process is a little different from what you outlined. You were correct in that the buggy drive is IDE 2. The DMA boxes on each IDE device (1 and 2) were checked. I ran NeroInfoTool (a great freeware by the way) and came up with this info regarding my system and the drive in question:

Drive Information
Drive : SONY CD-RW CRX700E
Type : CD-RW Recorder
Firmware Version : 1.4u
Buffer Size : 8 MB
Date : ?
Serial Number
Vendor Specific : Sep11 ,2001
Drive Letter : E:\
Location : 1:0
Mechanism : Tray
Read Speed : 12 , 8 , 4 , 2 X
Write Speed : 8 , 4 , 2 X

Read CD Text : Yes
Return C2 Pointers : Yes
Read CD-R : Yes
Read CD-RW : Yes
Read BD-ROM : No
Read BD-R : No
Read BD-RE : No
Read Digital Audio : Yes
Read CD+G : No
Read VideoCD : Yes

Write CD-R : Yes
Write CD-RW : Yes
Write BD-R : No
Write BD-RE : No
BufferUnderrun Protection: No
Mount Rainier : No
Modes : Packet, TAO, DAO, SAO, RAW SAO, RAW DAO, RAW SAO 96, RAW DAO 96

Disc Information (E:\)
Type : Blank CD-R
CD-R(W) Info : Sony, CD-R, 79:59.74

Interface Information
Adapter 1
Description : Primary IDE Channel

Description : ESDI_506.pdr
Company : Microsoft Corporation
Version : 4.90.3000
Description : ESDI_506 Virtual Device (Version 4.0)

Attached Devices
Type : Disk Drive
DMA : On
Description : LG DVD-ROM DRN8080B
Type : CD-Rom Drive
DMA : On
Autorun : Off

Adapter 2
Description : Secondary IDE Channel

Description : BayMgr.Mpd
Company : Softex Inc.
Version : 1.00.5
Description : BayManager Miniport Driver

Attached Devices
Description : SONY CD-RW CRX700E
Type : CD-Rom Drive
DMA : On
Autorun : Off

Software Information
Operating System : Windows ME
DirectX : DirectX 9.0c

Description : Nero Burning ROM
Version : 6, 6, 1, 4
Company : Ahead Software AG
Version Check : Ok

Description : Nero StartSmart
Version : 2, 1, 0, 5
Company : Ahead Software AG

Description : Cover Designer
Version : 2, 3, 1, 3
Company : Nero AG

Description : Nero BackItUp Application
Version : 1, 2, 0, 61
Company : Ahead Software AG

Hardware Information
CPU : 800 MHz
Bus Speed : 100 MHz
Motherboard : Dell Inspiron 8000
System : Dell Inspiron 8000
BIOS : Dell A02
Memory : 127 MB
Sound : ESS Maestro3
Video : RAGE MOBILITY 128 AGP 4X (English)

I'm not sure what the problem really is, but it seems odd that the buffer size is only 8MB. That seems small. Perhaps that would be the problem?

As an aside, I can play an audio CD from the other CD (IDE 1) without any problems. It would not seem to me that there is a soundcard/driver issue. It seems that I cannot play an audio CD from the CDRW (IDE 2) and can only burn at 2x (using different software--EAC, Nero). I will uncheck DMA, reboot and re-check DMA and see if that helps.

Again, thanks for your guidance.


2006-02-24, 11:17 PM
No, 8 MB is more than enough, mine is 2 MB.

DMA is on for all devices, so you're alright there.

Have you been using different media lately, and what type of media do you use? Media can be a major factor when it comes to writing speeds.

2006-02-25, 03:33 PM
I have been using Sony CDR for a few years now. According the the windows ME diagnositics testing it showed "IDE Device Failed" and the reason was that there was "No Audio Output". I have tried a non-CDR audio disc and still get the same result.

It remains a mystery. Thanks for your help though.


2006-02-28, 02:27 PM
Although I have updated all drivers and firmware, I still got errors. What I did was uninstalled Nero (and it's update) and then re-installed Nero without the update.


Now things are back to where I can burn discs at 8x without any "Cannot start DAO" error.

Sometimes change is a bad thing.