PDA

View Full Version : Some sessions green, some yellow?


aikox2
2005-09-02, 08:25 PM
This is very perplexing to me, and I am a huge proponent of green lights, so I must resolve this.

I have always had green lights, and I did not change anything in my setup (BitTornado, ports forwarded in my router to my static IP), but right now i have three torrents open, and two are green lights, and one is yellow. I have had this problem with other torrents for the past few days, where some are green and some are yellow!

Any idea what would cause this, and how to resolve it?

Thanks,
Aiko

TheMamba
2005-09-02, 09:25 PM
Different trackers or all the same?

TTD tracker?

aikox2
2005-09-02, 09:45 PM
Well, right now I have two going on the same tracker (not TDD), and one is green and one is yellow! I have one going on TDD that is green, and I don't recall getting a yellow here, but I have gotten a yellow on a third tracker as well, but have also gotten green on that third tracker.

Like I said, I never used to get yellow anywhere.

Aiko

BTW, they're turning the traffic lights blue tomorrow

aikox2
2005-09-02, 10:39 PM
Hmm, while screwing around trying to resolve this, I went into the router and set the port forwarding on UDP as well; I only had the TCP forwarding. After changing that, my yellow lights turned green! It just strikes me as odd that it never used to make a difference, and that it didn't matter on some torrents but did on others!

It's no wonder people get so frustrated and can't fix their problems. It seems the only consistent is inconsistency.

Aiko

TheMamba
2005-09-03, 08:05 AM
:clap: :clap:

spiritinaphoto
2005-09-24, 03:20 AM
Hmm, while screwing around trying to resolve this, I went into the router and set the port forwarding on UDP as well; I only had the TCP forwarding. After changing that, my yellow lights turned green! It just strikes me as odd that it never used to make a difference, and that it didn't matter on some torrents but did on others!

It's no wonder people get so frustrated and can't fix their problems. It seems the only consistent is inconsistency.

Aiko
I was looking through the options on Azureus today, and I think I stumbled across why this fix works. (What I saw made me remember this thread.)

One option under the 'Tracker -> Client' section says "Enable UDP tracker client protocol. This uses the same port number as the TCP server." This option is apparently enabled by default in Azureus.

I'm guessing that BitTornado must allow UDP access as well, and that was what made your fix work.

I think this is a pretty important thing, because conventional knowledge says that it's only TCP ports that need forwarding for BT use, and yet what we've accidentally stumbled upon is that several BT clients do use UDP ports as well.