PDA

View Full Version : OSX 10.8.3 Firewall!


ebsound
2013-06-20, 08:33 PM
I have an iMac and I'm using Vuze. I recently upgraded to OSX 10.8.3 and all seemed fine for a few days. Now, I am able to download but almost never upload. Whenever I come here, it says that I am firewalled. I've used my network utility and it shows my port, 6881, is open. I ping and everything seems fine. However, canyouseeme times out and says that it cannot see me. In the past, I had to set a static IP address which seems impossible after the update. I have my firewall turned off and still nothing. Not knowing what else to try, I notice my router has an address, 10.0.1.1, so I scanned that for open ports in the appropriate range and it says there are no open ports. My only "router" is a cheap Belkin 1 to 8 connector that I've had for a long time and never had a problem with. Not sure if the router address scan is legitimate. It is odd that, occasionally, I am not firewalled and everything works fine (about once in every ten boot ups). Can anyone help? The new software doesn't seem to allow much tinkering and I like to share!

U2Lynne
2013-06-21, 11:35 AM
It doesn't sound like an OSX firewall issue, it sounds like an issue with your router. You would need to forward your ports through it.

ebsound
2013-07-06, 10:41 PM
So, I solved it. It goes like this:
1) Open System Preferences.
2) Open Network.
3) Highlight your Wi-Fi.
4) Hit Advanced button.
5) Hit TCP/IP tab.
6) Write down your IPv4 Address. (probably 10.0.1.something).
7) Open your AirPort Utility.
8) Highlight your Airport. A little window will open.
9) Hit the Edit Button.
10) Hit the Network tab.
11) Hit the plus sign (+) under the Port Settings window.
12) Select Personal File Sharing in the Description pull down menu.
13) Enter the IPv4 address in the Private IP Address field.
14) Enter your port in the Public TCP Ports and Private TCP Ports fields.
15) Hit Save and then Update. Let it update and you are set.

AAR.oner
2013-07-08, 09:20 AM
cheers for the info ebsound!

unfortunately, those of us on 10.7 don't seem to have the same options...i'm lookin into using the WaterRoof GUI at the moment, will update for the other 10.7 folks if i can get it figured out